ComposicaDMetal Documentation V2.4

Ultimate Filament Winding

Introduction

Composicad is a new kind of software for filament winding. Composicad focuses on the whole part, rather than the individual wound layers. Using Composicad to program can save significant amounts of time for the most common filament wound objects - pipes, tanks and figures of revolution.

The Metal version of Composicad has seven individual packages:

  • Bronze - for pipes and tubes
  • Titanium - for spars
  • Iron - for elbows and ducts
  • Cobalt - for Tee shapes
  • Silver - for tanks and vessels
  • Gold - for figures of revolution
  • Chromium - for post processing fiber paths

Depending on the license, individual packages may or may not be installed. Packages may also have one or more options:

  • FEA mesh output option for all packages except Cobalt
  • Simulation option for all packages
  • Script option for all packages
  • Database option for all package
  • From 1-8 machine setups as well as the No Machine output option
  • 2,3,4,5,6 axes configurations as well as robotic output
  • Translation of Menus and dialogs
  • Increased number of lamina and/or materials

The title of the main dialog shows the various packages and options which are installed.

The Main menu of Composicad:

Main Menu

The Composicad Approach

To make a filament wound part using Composicad is straight forward.

  1. Define the material to wind with
  2. Select the part type - pipe, vessel, figure of revolution, spar, duct. tee, or post processor
  3. Define the original mandrel shape and general part information
  4. Define the laminate sequence to be wound including transitions
  5. Select the machine output to generate

Composicad stores all of the information it is using in a file called the part (or project) state file. This file is named ccm_state.prj. It is normally stored in the directory from where Composicad is being run. See Other Options for more information about this state file.

As you enter information for your part (project) Composicad will calculate everything it can based on the information it has. Thus as you enter the part information, Composicad is calculating the fiber paths, the machine motions, the new mandrel shape and many other kinds of data that it needs.

You can save (and load) the program state as a Project file using the Load and Save Menu Items. This file contains all of the information associated with the part. Normally, Composicad only generates a few files - the state file and Project file, and the required machine control output files (in the format for the specific machine controller). Other files may be optionally generated if needed.

Data Flow

The graph above shows the way that data flows through Composicad. Because Composicad is parametric (all calculations are based on the previous data calculated), it is very easy to make changes to the part and then Composicad recalculates all of the data needed to wind that part.

A key to this process is the new mandrel shape generator. As a part is being wound, the shape of the part is changing, due to the thickness of the material being wound onto the part. Composicad uses a several different algorithms to calculate each new mandrel shape. The choice of the method is determined by what data is needed.

 

Project

The Project Menu:

Part Menu

 

Using the Project Menu you can (dependent on which modules are installed in the specific license):

  • Select the type of part to generate:
    • Pipe - pipes or other tubular (or tapered with the Taper Option) shapes
    • Tank or Vessel - typical pressure or other vessels
    • Figure of Revolution - any axisymmetric figure of revolution
    • Spar - straight constant cross section parts
    • Curve - round cross section parts with a curve
    • Tee - pipe tees
    • Post processor - import a path file directly
  • Run a script
  • Import a dxf or stl format mandrel shape into one of the part generators
  • Load/Save a project (part)
  • Print part data
  • Use a part data base
  • Exit Composicad

 

Bronze - Pipes and Tubes

Pipe

The basic filament wound shape is a tube. In the bronze package the fiber is assumed to turn around on the pipe (the yellow area above is the turn around area). At this time pin ring turnarounds are not supported directly.

The bronze package can also support a tapered shape:

Taper

 

Silver - Tanks and Vessels

Tank

A typical vessel consists of a cylindrical section with a dome closure on each end. Normally, at least one of the domes has a pole opening. This pole is usually used to support the mandrel in the winding machine. The yellow section above shows an elliptical dome. The bright yellow indicates the pole pieces (one on each end above).

The silver package supports both elliptical and isotensoid domes with non-symmetric poles:

Non symmtrical

The above figure shows a nonsymmetrical bottle. The bright yellow is the pole pieces and support shafts, the pink (salmon) color is an isotensoid dome and the mustard color is an elliptical dome.

 

Gold - Figure of Revolution

Figure of Revolution

Figures of revolution are parts that have a circular cross section. They are made by revolving a contour around an axis. These parts are the most specialized and most difficult to wind. Composicad supports all figures of revolution that can be wound. The gold package has a more generalized mandrel generator and you can also import a general mandrel contour.

 

Chromium - Post Processor

Post Processor

The chromium package is used to bring in fiber paths that are generated in other ways and use the post processing capabilities of Composicad to generate machine output files. The chromium package can import mandrel shapes as well as only a fiber path.

 

Titanium - Spar

Spar

The titanium package is used to wind constant cross section parts that are not round ie. a spar or mast shape.

 

Iron - Curve

Curve

The iron package is used to wind round cross section parts with a curve - ie elbows or ducts.

 

Cobalt - Pipe Tees

Tee

The cobalt package is used to wind tees. The lengths and diameters of the branch and run can be specified as well as the blend radius.

 

Load & Save a Project

You can save the current Composicad project state as a part file. Use the "Load Project..." or "Save Project..." Menu Items:

Load and Save a Part

Clicking Load or Save brings up the file dialog box:

Save File Dialog

Select the file name (or type it in) and click Save (Open). The project files have an extension of ".prj".

 

Laminate

The Laminate menu.

Laminate Menu

Click "Laminate Table..." to go to the currently selected part Laminate Dialog.

Click "Materials..." to go to the Materials dialog.

Click the "Export to ESAComp..." to go to the ESAComp Export dialog.

Click the "Export to WCM..." to go to the WCM (Wound Composite Module of ABAQUS) Export dialog.

Click the "Export to FEA..." to go to the FEA Export dialog.

Click "Save As..." to go to the Save As dialog to save the part or mandrel as an .stl (stereo lithography file)

 

Machine

ComposicaD can support multiple machine output formats. Each machine output has two parts: a Definition and a Controller. Each separate part controls specific attributes of the output process. Each dialog is accessible via the Machine Menu:

Select Menu

The specific controller used for the machine definition is selected via the Controller menu:

Controller Menu

A check mark shows the currently selected controller for that machine. These options may not be enabled on all versions of Composicad.

 

Select a Machine

The machine is selected by clicking the Select item in the Machine menu. A check mark next to the machine indicates which machine output is currently selected.

When selecting a different machine, a message box will pop up asking you if you want to calculate and save the new machine output:

Machine confirmation

No Machine output may also be selected by clicking None. This is useful when doing an analysis - Burst Pressure or FEA - to speed up the computations, since no machine output is generated, only the fiber paths (lamina).

Load and Save a Machine setup

A complete set of machines can be Loaded or Saved using the "Load All..." or "Save All..." menu Items. A complete machine set file has the extension ".mcs".

A single machine format may also be saved and loaded using the "Save..." and "Load..." items from the individual Machine Menus. Individual Machine setup files have the extension ".mac".

 

Units

The units used in Composicad may be selected from the Options Menu:

Units

Just click on the desired units. A dot shows the currently selected units. All values internal to Composicad are stored in metric units. Most files generated by Composicad use metric units.

 

Languages

The language used in composicad may be selected from the Options Menu:

Language

Currently English, French and German are fully supported, with limited support for Flemish (Dutch), Spanish, Portuguese, Spanish, Italian, Chinese and Japanese.

 

Other Options

 

Help

Composicad has a built in help system which is implemented through web pages. Composicad ships with the current version of the help system.

Help

 

On-line Help

Additional (and/or newer) help may be available on-line (internet access required). Clicking here opens the help page on the Composicad Web site.

 

About

The About box shows information about the Version of Composicad and the registered user (License):

About

The About box shows which packages and options are installed and the version number and information about the licensed user.

 

Additional Information

The following are pdf documents:

Tips for using Composicad

Why Composicad for Pressure Vessels

Composicad Advantages

Saving and Loading Machine Setups

Expired License

Instalation Instructions

Configuring the Machine Definition and Controller Setup

Using the filters in Composicad

Tips for Next Mandrel Generation

 

 

Documentation

   Introduction

   Approach


Main Menu Bar

Project

   Pipe

   Tanks & Vessel

   Figure of Revolution

   Spar

   Curve

   Tee

   Post Processor

   Import Mandrel

   Run Script

   Load & Save a Project

   Print

   Data Bases

Laminate

   Laminate Dialog

   Materials Dialog

   FEA

   Export Dialog

Machine

   Simulation

   Machine Select

   Machine Definition

   Machine Controller

   Machine Load & Save

Options

   Units

   Language

   Other Options

Help

   Help

   On-line Help

   About


Other Topics

Rules

The Path Displays

The Graph Displays

Data Options Dialog

Output Options Dialog


Using the Mouse

Using the Toolbar

Calculate a Value

Auto Name


Definitions

Errors


Additional Information

 

©2014 Composicad - All rights reserved. This page updated April 30, 2014
Composicad, the ball and cage Composicad logo, the stylized C logo and the ComposicaD logo are trademarks of Composicad